// Free shipping on US Orders over $99* //

Resources - FAQs - Detail

FAQ ANSWER DETAIL


Tachometer does not work with my LS Engine Swap Application. Why?

This is a very common inquiry after folks like yourself install a late model LS engine into an earlier vehicle. Your computer wire harness has a tachometer signal wire (in most cases it is a white wire), so why won’t it work? After all, the wire harness manufacturer put it there, and maybe even labeled it as tachometer signal. What’s the problem?

The issue here is that when the computer was flashed/programmed to delete security features and certain emissions features, this can many times directly affect the tachometer signal. It can severely weaken the signal, and in some cases it can also eliminate the signal. Even though your scan tool may show RPM in the data stream, the driver for this signal in the computer can still be weak or dead.

So, let’s get to how to fix this problem. The quickest, and cheapest way to fix this issue would be to use a “pull up resistor”. This is simply a resistor that bridges across the already existing signal wire and a power wire. When doing this you will leave the tachometer still connected as it normally would be. Connect one leg of the resistor to the signal wire on the tachometer, and the other leg of the resistor to the power wire of the tachometer. I recommend starting with a 10K-1/2 watt resistor, though you may go as low as 5K- ½ watt. (FYI, K = 1,000 ohms, therefore as an example a 5K is 5,000 ohms).

If the tachometer starts to function, then all you have to do is make sure that you set your tachometer for 4 cylinder (2-pulse) for an accurate reading, and finish up your installation. LS engine computers output a 4 cylinder signal even though these are V8 engines. Please also note that if your tachometer is set to 8 cylinder, this will not keep your tachometer from operating. It would still operate, though only at half speed.

What if the pull up resistor trick did not work? In this case you are not dealing with a weak signal, but rather a dead signal, or no signal. In this case you may use an Auto Meter Tachometer Adapter. The adapter will not use anything from the computer, or the original tachometer signal wire.

The Tachometer Adapter will wire in series between both banks of coils and their power supply. The adapter will not have anything to do with the trigger, or signal side of the coils. It gets wired in so that all ignition power (the 12v power supplied to the coils) is routed into, through, and back out of the adapter. The adapter then simply monitors current flow through the adapter every time a coil is fired, and the adapter then outputs a signal based on this.

The adapter will produce a standard 8 cylinder (4 pulse) tachometer signal.

You potentially have three options here with the adapter in terms of model numbers. Model 9117 is the tachometer adapter by itself that you have to wire in. Model 9123 is the tachometer adapter with a plug and play LS specific harness. This makes the installation very easy with no cutting of the original harness. Model 2189 is the LS plug and play harness without the adapter (in case you already have a 9117 adapter). The 9123 & 2189 will work up through 2013 model year LS engines.

So you might ask “Why cant I wire in the 9117 with only one bank of coils, and set the tachometer as 4 cylinder?”. This is a good question with a good answer. While it would work, the result would be a very erratic or jumpy signal. This is because all four coils on one bank do not fire 90 degrees apart from each other. They are off set due to the firing order. Therefore if you need to use a tachometer adapter, either wire both banks of coils power through the adapter, or use the Auto Meter LS harness to make the job really easy.

 

Tachometer shown with 10k pull-up resistor

Tachometer shown with 10k pull-up resistor